# Universal Messaging support on Cumulocity Apama 10.15 (under RHEL)

**URL:** <https://community.cumulocity.com/t/universal-messaging-support-on-cumulocity-apama-10-15-under-rhel/12321>\
**Category:** Forum\
**Tags:** analytics\
**Created:** [May 27, 2025, 8:58am UTC](https://community.cumulocity.com/t/universal-messaging-support-on-cumulocity-apama-10-15-under-rhel/12321 "2025-05-27T08:58:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ricardo.siguero1](https://dub1.discourse-cdn.com/flex005/user_avatar/community.cumulocity.com/ricardo.siguero1/32/32261_2.png) [@ricardo.siguero1](https://community.cumulocity.com/u/ricardo.siguero1)\
**Post date:** [May 27, 2025, 8:58am UTC](https://community.cumulocity.com/t/universal-messaging-support-on-cumulocity-apama-10-15-under-rhel/12321/1 "2025-05-27T08:58:08Z")

</div>

Hi,

When running a Cumulocity Apama correlator 10.15.6.3.562060 (build rel/10.15.6.x@0c9bbd41a26) running under RHEL 8.10, we get the following error:

2025-05-27 09:01:35.182 ERROR [139693589286848] - Connectivity plug-ins: Exception while creating chain manager umTransport.umManager: Error while opening: **libUMConnectivity.so** or a library it depends on for the plug-in: umManager: libUMConnectivity.so: cannot open shared object file: No such file or directory  
2025-05-27 09:01:35.182 ERROR [139693589286848] - Failed to initialize correlator: Connectivity plug-ins startup failure

Comparing to a previous installation of Apama (made by means of the Software AG’s installer) the library mentioned above is found under the Apama/lib/ directory:

$ find -name libUMConnectivity.so -print  
./software/ **Apama/lib/libUMConnectivity.so**

If we additionally look for this resource on an related Universal Messaging installation (also done by the Software AG’s installer), this library is not located anywhere under its directory tree.

Bearing in mind that, from now on, both products (Apama and Universal Messaging) will be evolved separately, it seems, unless I’m mistaken, IBM might be the only responsible of dealing with this issue.

Thanks

Ricardo

---

<div class="post-metadata">

**Author:** ![ricardo.siguero1](https://dub1.discourse-cdn.com/flex005/user_avatar/community.cumulocity.com/ricardo.siguero1/32/32261_2.png) [@ricardo.siguero1](https://community.cumulocity.com/u/ricardo.siguero1)\
**Post date:** [May 29, 2025, 8:08am UTC](https://community.cumulocity.com/t/universal-messaging-support-on-cumulocity-apama-10-15-under-rhel/12321/2 "2025-05-29T08:08:28Z")

</div>

We’re using the wrong install package. The required one is the _dbp_ package.  
Regards.  
Ricardo.
